Re: [PATCH 1/2] mm/damon/core: preserve the caller's quota in damon_new_scheme()

From: Karl Mehltretter

Date: Wed Sep 23 2026 - 17:48:30 EST


On Tue, Sep 22, 2026 at 05:08:44AM +0100, SJ Park wrote:
> To calrify my opinion more, "caller's quota" feels unclear to me. I hope it to
> be more clear that it means "the quota that is passed as a parameter to the
> function".

I've made it explicit that this means the quota passed as a parameter
to damon_new_scheme().

> > >
> > > damon_commit_ctx() first copies the running context into a temporary
> > > context for validating the proposed parameters.
>
> I'd prefer using the term, 'commit' instead of 'copies' for clarity.

Changed to "commit" for the context operation.

> Now I understand you added the comment for commit 60bd24f272d0. I think Fixes:
> should also be 60bd24f272d0.

Agreed. I checked the diff and earlier callers. That commit first passes
the running context as the source. v2 uses it with a plain Cc: stable.

The LLM suggested the wrong tag, and I didn't notice it when checking it.

v2 is rebased on mm-new and passes all 46 KUnit tests on x86-64 and
i386. I'll send it soon.

Thanks,
Karl