Re: [PATCH v4 3/4] virt: tdx-guest: Use a variable to store the Quote buffer size

From: Peter Fang

Date: Tue Sep 22 2026 - 17:37:35 EST


On Tue, Sep 22, 2026 at 10:34:02AM -0700, Dave Hansen wrote:
> On 9/22/26 09:30, Peter Fang wrote:
> > The pointer to this buffer is "void *quote_data" which probably needs a
> > better name too.
>
> Yes, please.
>
> Also, does it really not have a type?

This exact issue was discussed in v3 [1]. Binbin had the same confusion.
I suggested changing it to "struct tdx_quote_buf *quote_buf". I think
that should work better overall.

I didn't include it in v4 because it needed to resolve a few
type-related wrinkles. I wasn't sure if it needed to be in this series.
I can certainly include it in the next version if you'd like.

[1] https://lore.kernel.org/all/8d20d04a-3503-42d5-8aa0-90b96aca2fe4@xxxxxxxxxxxxxxx/