Re: [PATCH] SUNRPC: use assign_bit() where applicable

From: Chuck Lever

Date: Tue Sep 22 2026 - 11:59:13 EST


On Sun, 20 Sep 2026 10:27:13 +0800, Peng Fan (OSS) wrote:
> Convert open-coded if/else with set_bit/clear_bit the assign_bit API.
>
> Done with Coccinelle semantic patch:
> // set_bit -> clear_bit => assign_bit
>
> @@
> expression cond, bit, addr;
> @@
>
> [...]

Applied to nfsd-testing, thanks! This narrow clean-up should be easy
to discover and apply as a pre-requisite should it ever conflict
with an LTS backport.

[1/1] SUNRPC: use assign_bit() where applicable
commit: 1a2b6be91033a31e13b676163be3e232201b1e3f

--
Chuck Lever