Re: [PATCH] printk: Remove preempt_disable() from __wake_up_klogd()
From: Sebastian Andrzej Siewior
Date: Tue Sep 22 2026 - 02:35:28 EST
On 2026-09-21 18:53:36 [+0206], John Ogness wrote:
> Hi Sebastian,
Hi John,
> I am responding for completeness...
>
> On 2026-09-11, Sebastian Andrzej Siewior <bigeasy@xxxxxxxxxxxxx> wrote:
> > didn't we want to rip out console_irqwork_blocked()?
>
> As I mention in a previous email [0], it provides other significant
> benefits. So we do not want to rip it out, but at some point we should
> rename it for its "true" purpose.
Then please do so. Right now it looks like a workaround for tegra20
which has been replaced with the lazy-irq-work workaround.
> John
Sebastian