Re: [PATCH v2 02/11] iio: adc: change from %ld to %pe for PTR_ERR() printing
From: Jonathan Cameron
Date: Mon Sep 21 2026 - 20:24:39 EST
On Tue, 22 Sep 2026 00:08:55 +0800
Chen-Yu Tsai <wens@xxxxxxxxxx> wrote:
> Jonathan,
>
> On Sat, Jun 13, 2026 at 4:06 PM Jernej Škrabec <jernej.skrabec@xxxxxxxxx> wrote:
> >
> > Dne četrtek, 4. junij 2026 ob 13:59:22 Srednjeevropski poletni čas je Vojtěch Krátký napisal(a):
> > > Replace numeric PTR_ERR() logging with the %pe format specifier
> > > so that error values are printed in a more readable form.
> > >
> > > This change was identified using a Coccinelle semantic patch.
> > >
> > > No functional change intended.
> > >
> > > Signed-off-by: Vojtěch Krátký <vo.kratky@xxxxxxxxx>
> >
> > Acked-by: Jernej Skrabec <jernej.skrabec@xxxxxxxxx>
>
> Any chance you can still pick this up?
Not without Andy's feedback being taken into account as
it seems to apply to this patch as well as the one he commented on
https://lore.kernel.org/all/CAHp75VcKGfzQePh0TzsNBKPjHxr=ey8uO=4_+_oaioSNKkS8_A@xxxxxxxxxxxxxx/
>
>
> Thanks
> ChenYu