Re: [PATCH 2/2] i2c: busses: use named initializers for acpi_device_id
From: Mika Westerberg
Date: Mon Sep 21 2026 - 00:53:26 EST
On Fri, Sep 18, 2026 at 02:01:51PM +0100, Pawel Zalewski wrote:
> Use a designated initializer for the acpi_device_id fields which makes the
> code more readable and consistent with how lists are initialized in the
> rest of the kernel code base. Also drop explicitly setting fields to 0
> where it is redundant.
>
> Unify the list terminator to have a single space between the brackets and
> no trailing comma.
>
> Unify list item alignment to have a single space padding between the
> brackets.
>
> Signed-off-by: Pawel Zalewski <pzalewski@xxxxxxxxxxxxxxxxxxxx>
> ---
> drivers/i2c/busses/i2c-amd-asf-plat.c | 2 +-
> drivers/i2c/busses/i2c-amd-mp2-plat.c | 2 +-
> drivers/i2c/busses/i2c-cros-ec-tunnel.c | 2 +-
> drivers/i2c/busses/i2c-designware-platdrv.c | 42 ++++++++++++++---------------
For i2c-dw:
Acked-by: Mika Westerberg <westeri@xxxxxxxxxx>