Re: [PATCH 1/2] i2c: i2c-core-acpi: use named initializers for acpi_device_id
From: Mika Westerberg
Date: Mon Sep 21 2026 - 00:50:30 EST
On Fri, Sep 18, 2026 at 02:01:50PM +0100, Pawel Zalewski wrote:
> Use a designated initializer for the acpi_device_id fields which makes the
> code more readable and consistent with how lists are initialized in the
> rest of the kernel code base. Also drop explicitly setting fields to 0
> where it is redundant.
>
> Unify the list terminator to have a single space between the brackets and
> no trailing comma.
>
> Signed-off-by: Pawel Zalewski <pzalewski@xxxxxxxxxxxxxxxxxxxx>
Acked-by: Mika Westerberg <westeri@xxxxxxxxxx>