Re: [PATCH 4/4] kconfig: tests: {old,save}defconfig: Forward dynamic keyword arguments
From: Julian Braha
Date: Sat Sep 19 2026 - 14:09:22 EST
On 9/17/26 14:38, Nicolas Schier wrote:
> Let kconfig test framework forward dynamic keyword arguments for
> 'olddefconfig' and 'savedefconfig' and update the _run_conf() calls in
> warn_changed_input to use the corrsponding wrappers instead.
>
> The warn_changed_input test needed to use _run_conf() as the
> {old,save}defconfig wrapper did not provide the necessary flexibility
> for common calls. With dynamic keyword arguments, there is no need to
> use the framework-internal _run_conf() any more.
>
> Signed-off-by: Nicolas Schier <n.schier@xxxxxxxxx>
This is certainly more readable, nice cleanup.
Reviewed-by: Julian Braha <julianbraha@xxxxxxxxx>