Re: [PATCH 2/5] lib/tests: string_helpers: drop unused parameters

From: Jonas Rebmann

Date: Thu Sep 17 2026 - 05:05:53 EST


On 2026-09-17 09:18, Andy Shevchenko wrote:
On Wed, Sep 16, 2026 at 07:38:07PM +0200, Jonas Rebmann wrote:
Drop the unused parameters from test_string_check_buf() to improve
readability.

We need to find a way how to use them in the error messages. This is a
regression in fb57550fcbd8 ("string: Convert helpers selftest to KUnit")
that drops them.

In that case I suppose I drop this patch in v2.

--
Pengutronix e.K. | Jonas Rebmann |
Steuerwalder Str. 21 | http://www.pengutronix.de/ |
31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-9 |