Re: [PATCH] scsi: zorro7xx: Use individual zorro_driver_data structures

From: Martin K. Petersen (Oracle)

Date: Wed Sep 16 2026 - 22:33:14 EST


On Mon, 31 Aug 2026 11:49:20 +0200, Geert Uytterhoeven wrote:

> Using an array of zorro_driver_data objects and referring to its
> elements by index obfuscates the code and is error-prone.
>
> Improve readability and reduce code size by replacing the array (which
> includes an unneeded sentinel) by individual zorro_driver_data objects.
>
>
> [...]

Applied to 7.4/scsi-queue, thanks!

[1/1] scsi: zorro7xx: Use individual zorro_driver_data structures
https://git.kernel.org/mkp/scsi/c/6b0f8a689ef3

--
Martin K. Petersen